Are you suddenly experiencing frequent lockouts of your user account after you have recently changed your password? One important thing to note is that IBM Integration Designer does store the user ID and password that you initially set up to use with the servers that you created.  As you can see in the image below and by double clicking on the server that you have configured in your local test environment (or any other servers for that matter), IID stores the username and password for how it connects to Process Center and your servers.

What can happen here if you use your own user account is that IID will store the credentials your first provided when you set this server up.  When you change your password for your user account, this will update in your LDAP or Active Directory; however, IID will repeatedly try to connect using your old credentials, ignoring any authentication failures.  So, after the usual three incorrect attempts, or whatever your policy is, the user account will become locked out.  This will continue until you lock you out until you change the credentials here on the Security screen in IID for the configured servers you have in place.

Ideally, IID should not be retrying the connection after it receives an authentication failure and it should prompt you for you new password.  Yet, at this time, the product does not have that capability.  So, there are two options that IBM provides: 1) Use a service ID with a non-expiring password for these servers, or 2) Modify the field in this properties screen for the server status interval (default is 5000 msec). If you increase this number to a much larger number, the user will have time to come into IID and change their credentials before the account becomes locked out again.

In my opinion, the latter is not really a solution. Actually, neither appear to be a true solution to the problem, but nonetheless, in my experience, I would use another ID other than your own user account.

  1. Hi Seth,
    I having same issue and I belive this is serious issue, hope IBM have done something(?).
    I know there two alternative you have given, but first option not possoble as is controled, second option i tried but still i am having the same issue. could you please let us know if there are any fix or better solution.
    Thanks Prakash

    • Hi Prakash,
      To my knowledge, for version 7.5.1, I am not aware of a fix, although I have not looked through Fix Central in a while. You may want to give that a try to see. When you change your password, you should come to the IID preferences and under Business Integration > Process Center, update your password there. You will also need to double click on your server in the Servers tab and then go to the Security section and update your password there. Save everything and then restart you workspace. This worked for me. Let me know!